Login
Nome utente:

Password:

Ricorda



Recupero password

Registrati!
Navigazione
Utenti più attivi
1 Defkon1
Defkon1
6518
2 slyss
slyss
3389
3 blueangel
blueangel
1921
4 ianez
ianez
1914
5 timgno
timgno
1520
6 urban
urban
1476
7 dantom
dantom
1233
8 Energiko
Energiko
1013
9 unico77
unico77
985
10 Kirky
Kirky
862
Utenti Online
24 utente(i) online
(20 utente(i) in Forum)

Iscritti: 0
Ospiti: 24

altro...


Naviga in questa discussione:   1 Utenti anonimi






Il mio sito xoops attaccato
#1
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
Tra ieri e questa notte il mio sito TXMod Xoops, è stato attaccato ed alcuni contenuti sono spariti, la homepage ha per so dei contenuti, protectore non funziona più viene fuori pagina bianca in amministrazione, funziona solo la lingua inglese anche se ho impostato la lingua italiana in preferenze.

Tra le schede si può notare che smarty non riceve bene le variabili, pur avendo controllato che i file hanno tutte le variabili giuste.

Credo che questo sia potuto accadere a causa della mia decisione di interrompere la registrazione al nuovo sito mobile.txmodxoops.org dopo continue registrazioni di utenti con nomi digitati a caso sulla tastiera del computer tipo: wetrygfdssdfggfdws@gfdssdfggfdsdg.com

Ieri infatti li ho eliminati tutti circa un venti

Se ripristino un vecchio backup, perdo tutti i contenuti che ho inserito fino ad ora .

Credo che bisogna rivedere qualcosina sulla sicurezza in xoops.

Inserito il:25/10/2012 8:37
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Il mio sito xoops attaccato
#2
Webmaster


Benutzerinformationen
Inserito:
24/8/2004 13:11
Da Ancona
raggruppare
Webmasters
Co-Webmaster
Messaggi: 6518
Non In Linea
Citazione:

timgno ha scritto:

Credo che bisogna rivedere qualcosina sulla sicurezza in xoops.


senza alcuna informazione sulle modalità di attacco e la debolezza sfruttata è, a mio avviso, errato scaricare la colpa sulla piattaforma.

per esperienza personale posso assicurarti che il 99% degli attacchi portati con successo a Xoops vengono da moduli datati o bacati, e/o funzionalità datate che soffrono di vulnerabilità.

andando a memoria direi che non ci sono vulnerabilità gravi in Xoops dal bug XSS della 2.0.9.2, mentre per i moduli posso fare decine di esempi di veri e propri colabrodo (myads, soapbox,...)

mi sembra strano che l'aver semplicemente chiuso le registrazioni possa aver generato il cataclisma che riporti, io ho siti che lavorano senza registrazioni e non ho mai avuto problemi di questo tipo.

Citazione:

Se ripristino un vecchio backup, perdo tutti i contenuti che ho inserito fino ad ora .


sembra demagogia, ma i backup vanno fatti e vanno fatti frequentemente. Forse rivedrei qualcosina sul tuo approccio alla sicurezza, più che quella della piattaforma...

Inserito il:26/10/2012 17:55
____________________
Visualizza immagine originale
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Il mio sito xoops attaccato
#3
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
in verità i backup li faccio generalmente ogni settimana, visto lo spazio web di tipo professionale condiviso possibili malfunzionamenti sono purtroppo frequenti.

Non do la colpa alla piattaforma, ma dopo aver chiesto chiarimenti all'host, i dati sono tornati a funzionare, purtroppo protector continua a dare pagine bianche in amministrazione sulle 3 schede più importanti.

Per quello dicevo che ci vorrebbe un tipo di codice che allerta in caso di aggiornamenti php, apache e mysql.

Penso proprio che il motivo sia dovuto a questi aggiornamenti che di solito danno avvertimenti prima dell'operazione agli utenti dello spazio hosting.

Xoops in generale non ha colpe, forse ho travisato un po la mia preoccupazione con la sicurezza che dovrebbe fornire protector dall'esterno. In effetti protector funziona bene dagli attacchi esterni ma non capisco perché non funziona come dovrebbe.
Sinceramente non ho mai guardato i codici di questo modulo. Non saprei dove cominciare. Anche perché con il php che sto studiando man mano non ho ancora dimestichezza totale.

Inserito il:26/10/2012 19:03
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto







Puoi vedere le discussioni.
Non puoi iniziare una nuova discussione.
Non puoi rispondere ai messaggi.
Non puoi modificare i tuoi messaggi.
Non puoi cancellare i tuoi messaggi.
Non puoi aggiungere nuovi sondaggi.
Non puoi votare nei sondaggi.
Non puoi allegare file ai messaggi.
Non puoi inviare messaggi senza approvazione.
Non puoi utilizzare tipo di argomento.
Non puoi utilizzare la sintassi HTML.
Non puoi utilizzare la firma.

[Ricerca avanzata]


XOOPS ITALIA © 2002-2012 - Powered by XOOPS