Login
Nome utente:

Password:

Ricorda



Recupero password

Registrati!
Navigazione
Utenti più attivi
1 Defkon1
Defkon1
6518
2 slyss
slyss
3389
3 blueangel
blueangel
1921
4 ianez
ianez
1914
5 timgno
timgno
1520
6 urban
urban
1476
7 dantom
dantom
1233
8 Energiko
Energiko
1013
9 unico77
unico77
985
10 Kirky
Kirky
862
Utenti Online
10 utente(i) online
(10 utente(i) in Forum)

Iscritti: 0
Ospiti: 10

altro...


Naviga in questa discussione:   1 Utenti anonimi






Update da 1.02 a 2.5.5
#1
Matricola


Benutzerinformationen
Inserito:
22/6/2013 13:32
raggruppare
Utenti Registrati
Messaggi: 8
Non In Linea
Buongiorno a tutti. Sono nuova e ho bisogno di un aiuto.
Devo fare l'aggiornamento dalla versione 1.02 alla 2.5.5. Sul server adesso c'è php 5.2.17 e l'amministratore del server ha installato Xoops 2.5.5
in una sottocartella del sito con un db nuovo, io entro con una user e pw che non c'erano nel db originale. Quindi mi ritrovo in una situazione
per me più inusuale del solito: se non ricordo male, nella versione che avevo l'aggiornamento si poteva fare dal pannello di amministrazione.
Ho cercato dati sull' installazione delle varie versioni ed ho visto che ad un certo punto c'era anche da installare un' applicazione di traduzione.
Avevo pensato di fare un'installazione graduale, tipo : prima passare dalla attuale alla 2.0 poi alla 2.5 ecc fino alla 2.5.5 ma non so se farei bene.
La situazione è troppo complessa per me in questo momento.
Qual'è il modo corretto per procedere?

Inserito il:23/6/2013 11:23
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#2
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
Buon giorno a te!

Ma la 1.02 risale a quasi dieci anni fa...!!!!

Sarà un tantino da seguire un mini tutorial per queste vecchie che già dall'aggiornamento da 2.0.18 è fastidioso.

La cosa che si dovrebbe fare ogni tanto è controllare nuovi aggiornamenti.

Non capisco perché l'amministratore del server installa direttamente nel tuo spazio xoops 2.5.5. Dovresti farlo tu se hai installatron o softaculus che ti permette di installare xoops in automatico.

Comunque qualsiasi cosa devi fare per iniziare fai un backup del database.

Prima di proseguire con l'aiuto dovresti fornirci maggiori informazioni sui moduli ed i temi che utilizzavi con xoops 1.02.

Non vorrei crearti equivoci, ma non sarà la versione di qualche modulo 1.02 e questo confonde un po le tue idee?

La versione di xoops installata sul tuo server la puoi verificare sul footer della pagina di amministrazione.

Appena ci dai queste informazioni di possiamo dire come aggiornare al meglio a xoops 2.5.5 premettendo che l'ultima versione attualmente è la 2.5.6

Inserito il:24/6/2013 12:46
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#3
Matricola


Benutzerinformationen
Inserito:
22/6/2013 13:32
raggruppare
Utenti Registrati
Messaggi: 8
Non In Linea
Grazie della risposta, timgno!

Hai ragione a farmi il 'cicchetto' sull'update, mi rendo conto che cercando di non essere prolissa forse sono stata troppo concisa, quindi ti darò qualche info in più sulla situazione:
il sito l'ha (l'aveva) fatto mio marito nel 2006/2007, ed è rimasto così fino ad aprile quando il sito non era più visibile e quando ho chiesto all'admin del server di sistemare, mi ha risposto che "sul server hanno messo PHP5 al posto di PHP3 che non si usa più e la mia versione di Xoops non viene letta". Mi ha installato Xoops 2.5.5 credo pensando di farmi un favore e perchè era convinto che avrei potuto fare l'aggiornamento direttamente dalla pagina di amministrazione. Non potendolo fare da lì, mi sono messa a studiare : oltre che per necessità, mi interessava in ogni caso. Ho anche trovato a casa il libro di Stefano Silvestrini e me lo sono studiato ma c'è anche il fatto che sarebbe stato forse più semplice partire da zero che da una situazione così.

Comunque già mi hai dato una dritta illuminante: versione 1.02 l'ho trovata nel file /modules/system/xoops_version e ho erroneamente pensato si riferisse a Xoops. Per forza che non trovavo niente facendo la ricerca per Xoops v 1.02 nei forum!! Invece nel file /include/version.php dice:
"define("XOOPS_VERSION","XOOPS 2.0.16");". E spero sia il riferimento giusto dal momento che il sito non è visibile.

L'admin del server mi ha detto che ha fatto il backup di tutto, db incluso.

I moduli installati sono:
content v0.5
extcal v2.04
multiMenu v1.8
myalbum v2.86
newbb v3.02
PDdownloads v1.2
PDlinks v1.0a
smartsection v2.13
system v1.02
xmmemberstats v2.0e
yogurt v2.9

Nel sito ci sono questi temi: default, obscene_v3_3c, phpkaox, scratchy, x2t ma l'unico che ha dei collegamenti al sito (nel file theme.html) è obscene_v3_3c quindi immagino sia quello usato.

Nella versione di Xoops 2.5.5, nella pagina di amministrazione/system overview dice che la versione di PHP è 5.2.17 quindi, se va bene, farei direttamente l'installazione di Xoops 2.5.6.

Grazie per la pazienza



Inserito il:24/6/2013 18:45
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#4
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
Prima di iniziare io in locale utilizzo WampServer per testare sia il Core, sia i moduli e sia i temi.

Se già stai facendo delle prove in locale, ti do dei link per aggiornarti meglio quali moduli e quali temi potrebbero interessarti per xoops 2.5.6

Quando vai in amministrazione dalla versione xoops 2.5.0, in ogni pagina index dei moduli ci sono delle label che ti indicano nei Controllo Configurazione la versione:

Vedi immagine sotto
Visualizza immagine originale


Leggi questa news su xoops.org per capire quali moduli sono compatibili ed aggiornati

xoops.org/modules/news/article.php?storyid=6441

Fai sapere tutti i passaggi che fai e scarica l'ultima versione di xoops dal link che ti ho dato prima dalla page c'è un bottone arancio in alto.

Inserito il:24/6/2013 19:48
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#5
Webmaster


Benutzerinformationen
Inserito:
24/8/2004 13:11
Da Ancona
raggruppare
Webmasters
Co-Webmaster
Messaggi: 6518
Non In Linea
2006/2007?

mi sembra strano che abbia usato una versione così antica come il ramo 1.x... sei sicura di quella versione?

Inserito il:25/6/2013 21:53
____________________
Visualizza immagine originale
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#6
Matricola


Benutzerinformationen
Inserito:
22/6/2013 13:32
raggruppare
Utenti Registrati
Messaggi: 8
Non In Linea
Buongiorno Defkon1,
innanzitutto mi scuso molto per il silenzio ma ho avuto alcune questioni urgenti da risolvere e ho avuto poco tempo per lavorare sull'aggiornamento.

Dunque, per rispondere alla tua domanda, come avevo scritto sopra, 'versione 1.02' l'avevo trovata nel file /modules/system/xoops_version e ho erroneamente pensato si riferisse alla versione di Xoops, invece non è così : la versione di Xoops installata è la 2.0.16, o almeno così è scritto nel file /include/version.php.

Continuo qui anche con la risposta a Timgno : ho installato WampServer 2.2, ho messo una copia del database nella cartella /class/database e ho modificato il mainfile.php settando 'XOOPS_ROOT_PATH' col percorso in locale.

A questo punto, aprendo 'localhost' da wampserver mi da il sequente errore:
- Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp\www\Radioamatore\include\common.php on line 96
- Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\wamp\www\Radioamatore\include\common.php on line 30
- Error: Unable to connect to database

E qui mi sono fermata perchè non so dove mettere le mani. Adesso cosa devo fare?
Grazie per l'aiuto

Inserito il:8/7/2013 15:18
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#7
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
Segui questo tutorial poi facci sapere

Inserito il:8/7/2013 19:54
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#8
Matricola


Benutzerinformationen
Inserito:
22/6/2013 13:32
raggruppare
Utenti Registrati
Messaggi: 8
Non In Linea
Ciao, sono tornata! Dopo l'ultimo post sono riuscita ad occuparmi di Xoops solo da una decina di giorni e ... sinceramente nn mi aspettavo di trovare tutti questi intoppi, comunque: ho smanettato parecchio, prova e riprova e riprova ancora. Risultato: sono riuscita ad installare la versione 2.5.4 ed aggiornarla alla 2.5.6, ma la traduzione italiana funziona solo se fatta prima dell'install di xoops. Ho installato (sempre in locale, sono ancora nella fase di smanettamento) la 2.5.6 ed anche qui la traduzione italiana la prende solo se fatta prima dell'installazione. Comunque questa è poca cosa.

Ho provato ad installare la 2.0.16 e la 2.3.3 (giusto per prova) ma non si connette al db, immagino dipenda dalla versione.

Ho quindi optato per fare il full upgrade dalla 2.0.16 alla 2.5.6 ma non parte nemmeno l'installazione : http://localhost/sito/upgrade/index.php = pagina bianca.

Cosa faccio adesso?

Inserito il:30/9/2013 19:39
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#9
Guru


Benutzerinformationen
Inserito:
16/5/2007 13:09
Da Cosenza
raggruppare
Utenti Registrati
Staff
Messaggi: 1520
Non In Linea
Ma in localhost non hai bisogno di fare upgrade basta mettere la cartella xoops2.5.6 nella root www.

Sul server è vero che bisogna fare così ma andrei per gradi e versioni

Inserito il:1/10/2013 0:24
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto


Re: Update da 1.02 a 2.5.5
#10
Matricola


Benutzerinformationen
Inserito:
22/6/2013 13:32
raggruppare
Utenti Registrati
Messaggi: 8
Non In Linea
Ciao Timgno,
forse non ho spiegato bene la situazione:
io ho installato wamp server in locale, e sempre in locale ho il sito, fatto con Xoops 2.0.16, e il db. Da quello che avevo capito, è buona norma aggiornare il sito in locale, vedere che tutto funzioni come si deve e poi caricare il tutto sul server, e questo è quello che sto cercando di fare.

Prima ho provato con alcune versioni di Xoops creando però un db nuovo ogni volta, per vedere cosa succedeva negli update, e poi ho provato, senza successo, l'update del sito v 2.0.16 (quello effettivo in locale) alla 2.5.6.

Ho sbagliato?

Inserito il:1/10/2013 1:19
Crea PDF dal messaggio Stampa Twitter Facebook Google Plus LinkedIn Del.icio.us Digg Reddit Mr. Wong relazione, rapporto In alto







Puoi vedere le discussioni.
Non puoi iniziare una nuova discussione.
Non puoi rispondere ai messaggi.
Non puoi modificare i tuoi messaggi.
Non puoi cancellare i tuoi messaggi.
Non puoi aggiungere nuovi sondaggi.
Non puoi votare nei sondaggi.
Non puoi allegare file ai messaggi.
Non puoi inviare messaggi senza approvazione.
Non puoi utilizzare tipo di argomento.
Non puoi utilizzare la sintassi HTML.
Non puoi utilizzare la firma.

[Ricerca avanzata]


XOOPS ITALIA © 2002-2012 - Powered by XOOPS